#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<p>)?\[shortcode\](<\/p>)?"
Local $sString = "<p>[shortcode]</p>" & @CRLF & _
"[shortcode]" & @CRLF & _
"Text [shortcode] text lorem [shortcode] ipsum" & @CRLF & _
"[shortcode]" & @CRLF & _
"<p>[shortcode]</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")