package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<p>)?\[shortcode\](<\/p>)?`)
var str = `<p>[shortcode]</p>
[shortcode]
Text [shortcode] text lorem [shortcode] ipsum
[shortcode]
<p>[shortcode]</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}