re = /(<p>)?\[shortcode\](<\/p>)?/
str = '<p>[shortcode]</p>
[shortcode]
Text [shortcode] text lorem [shortcode] ipsum
[shortcode]
<p>[shortcode]</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end