const regex = /(<p>)?\[shortcode\](<\/p>)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p>)?\\[shortcode\\](<\\\/p>)?', 'g')
const str = `<p>[shortcode]</p>
[shortcode]
Text [shortcode] text lorem [shortcode] ipsum
[shortcode]
<p>[shortcode]</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}