// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<p>)?\[shortcode\](<\/p>)?").unwrap();
let string = "<p>[shortcode]</p>
[shortcode]
Text [shortcode] text lorem [shortcode] ipsum
[shortcode]
<p>[shortcode]</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}