const regex = /<span id=["'](ctl00_.+|other_ids)["']>(.+?)<\/span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span id=["\'](ctl00_.+|other_ids)["\']>(.+?)<\\\/span>', 'gm')
const str = `<span id="ctl00_BodyContentPlaceHolder_lblDescription">Random Description</span>
<span id='ctl00_BodyContentPlaceHolder_lblDescription'>Random Description</span>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}