re = /<span id=["'](ctl00_.+|other_ids)["']>(.+?)<\/span>/m
str = '<span id="ctl00_BodyContentPlaceHolder_lblDescription">Random Description</span>
<span id=\'ctl00_BodyContentPlaceHolder_lblDescription\'>Random Description</span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end