$re = '/<span id=["\'](ctl00_.+|other_ids)["\']>(.+?)<\/span>/m';
$str = '<span id="ctl00_BodyContentPlaceHolder_lblDescription">Random Description</span>
<span id=\'ctl00_BodyContentPlaceHolder_lblDescription\'>Random Description</span>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);