package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\W|^)("campaignName": "HTML Summer PAID")(\W|$)`)
var str = `{
"id": "1",
"method": "store",
"params": {
"model": "Impression",
"objects": [
{
"campaignName": "HTML Summer PAID",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.808
},
{
"campaignName": "Nested: Paid Offer 1",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 2",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 3",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.81
}
]
},
"jsonrpc": "2.0"
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}