$re = '/(\W|^)("campaignName": "HTML Summer PAID")(\W|$)/';
$str = '{
"id": "1",
"method": "store",
"params": {
"model": "Impression",
"objects": [
{
"campaignName": "HTML Summer PAID",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.808
},
{
"campaignName": "Nested: Paid Offer 1",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 2",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 3",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.81
}
]
},
"jsonrpc": "2.0"
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);