import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\W|^)(\"campaignName\": \"HTML Summer PAID\")(\\W|$)";
final String string = "{\n"
+ " \"id\": \"1\",\n"
+ " \"method\": \"store\",\n"
+ " \"params\": {\n"
+ " \"model\": \"Impression\",\n"
+ " \"objects\": [\n"
+ " {\n"
+ " \"campaignName\": \"HTML Summer PAID\",\n"
+ " \"campaignTypeImpressionNumber\": 3,\n"
+ " \"campaignTypeSessionImpressionNumber\": 1,\n"
+ " \"eventName\": \"mainLto3\",\n"
+ " \"eventNumber\": 1,\n"
+ " \"impressionNumber\": 1,\n"
+ " \"inAppStatus\": \"paying\",\n"
+ " \"isDefaultConfig\": false,\n"
+ " \"maxLevel\": 0,\n"
+ " \"mode\": \"default\",\n"
+ " \"parameters\": {\n"
+ " \"tleName\": \"summertle\"\n"
+ " },\n"
+ " \"sessionEventNumber\": 1,\n"
+ " \"sessionImpressionNumber\": 1,\n"
+ " \"sessionNumber\": 2,\n"
+ " \"subscriptionStatus\": \"free\",\n"
+ " \"timestamp\": 1659778581.808\n"
+ " },\n"
+ " {\n"
+ " \"campaignName\": \"Nested: Paid Offer 1\",\n"
+ " \"campaignTypeImpressionNumber\": 3,\n"
+ " \"campaignTypeSessionImpressionNumber\": 1,\n"
+ " \"eventName\": \"mainLto3\",\n"
+ " \"eventNumber\": 1,\n"
+ " \"impressionNumber\": 1,\n"
+ " \"inAppStatus\": \"paying\",\n"
+ " \"isDefaultConfig\": false,\n"
+ " \"maxLevel\": 0,\n"
+ " \"mode\": \"default\",\n"
+ " \"parameters\": {\n"
+ " \"tleName\": \"summertle\"\n"
+ " },\n"
+ " \"sessionEventNumber\": 1,\n"
+ " \"sessionImpressionNumber\": 1,\n"
+ " \"sessionNumber\": 2,\n"
+ " \"subscriptionStatus\": \"free\",\n"
+ " \"timestamp\": 1659778581.809\n"
+ " },\n"
+ " {\n"
+ " \"campaignName\": \"Nested: Paid Offer 2\",\n"
+ " \"campaignTypeImpressionNumber\": 3,\n"
+ " \"campaignTypeSessionImpressionNumber\": 1,\n"
+ " \"eventName\": \"mainLto3\",\n"
+ " \"eventNumber\": 1,\n"
+ " \"impressionNumber\": 1,\n"
+ " \"inAppStatus\": \"paying\",\n"
+ " \"isDefaultConfig\": false,\n"
+ " \"maxLevel\": 0,\n"
+ " \"mode\": \"default\",\n"
+ " \"parameters\": {\n"
+ " \"tleName\": \"summertle\"\n"
+ " },\n"
+ " \"sessionEventNumber\": 1,\n"
+ " \"sessionImpressionNumber\": 1,\n"
+ " \"sessionNumber\": 2,\n"
+ " \"subscriptionStatus\": \"free\",\n"
+ " \"timestamp\": 1659778581.809\n"
+ " },\n"
+ " {\n"
+ " \"campaignName\": \"Nested: Paid Offer 3\",\n"
+ " \"campaignTypeImpressionNumber\": 3,\n"
+ " \"campaignTypeSessionImpressionNumber\": 1,\n"
+ " \"eventName\": \"mainLto3\",\n"
+ " \"eventNumber\": 1,\n"
+ " \"impressionNumber\": 1,\n"
+ " \"inAppStatus\": \"paying\",\n"
+ " \"isDefaultConfig\": false,\n"
+ " \"maxLevel\": 0,\n"
+ " \"mode\": \"default\",\n"
+ " \"parameters\": {\n"
+ " \"tleName\": \"summertle\"\n"
+ " },\n"
+ " \"sessionEventNumber\": 1,\n"
+ " \"sessionImpressionNumber\": 1,\n"
+ " \"sessionNumber\": 2,\n"
+ " \"subscriptionStatus\": \"free\",\n"
+ " \"timestamp\": 1659778581.81\n"
+ " }\n"
+ " ]\n"
+ " },\n"
+ " \"jsonrpc\": \"2.0\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}