use strict;
my $str = '{
"id": "1",
"method": "store",
"params": {
"model": "Impression",
"objects": [
{
"campaignName": "HTML Summer PAID",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.808
},
{
"campaignName": "Nested: Paid Offer 1",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 2",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.809
},
{
"campaignName": "Nested: Paid Offer 3",
"campaignTypeImpressionNumber": 3,
"campaignTypeSessionImpressionNumber": 1,
"eventName": "mainLto3",
"eventNumber": 1,
"impressionNumber": 1,
"inAppStatus": "paying",
"isDefaultConfig": false,
"maxLevel": 0,
"mode": "default",
"parameters": {
"tleName": "summertle"
},
"sessionEventNumber": 1,
"sessionImpressionNumber": 1,
"sessionNumber": 2,
"subscriptionStatus": "free",
"timestamp": 1659778581.81
}
]
},
"jsonrpc": "2.0"
}';
my $regex = qr/(\W|^)("campaignName": "HTML Summer PAID")(\W|$)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}