# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\W|^)(\"campaignName\": \"HTML Summer PAID\")(\W|$)"
test_str = ("{\n"
" \"id\": \"1\",\n"
" \"method\": \"store\",\n"
" \"params\": {\n"
" \"model\": \"Impression\",\n"
" \"objects\": [\n"
" {\n"
" \"campaignName\": \"HTML Summer PAID\",\n"
" \"campaignTypeImpressionNumber\": 3,\n"
" \"campaignTypeSessionImpressionNumber\": 1,\n"
" \"eventName\": \"mainLto3\",\n"
" \"eventNumber\": 1,\n"
" \"impressionNumber\": 1,\n"
" \"inAppStatus\": \"paying\",\n"
" \"isDefaultConfig\": false,\n"
" \"maxLevel\": 0,\n"
" \"mode\": \"default\",\n"
" \"parameters\": {\n"
" \"tleName\": \"summertle\"\n"
" },\n"
" \"sessionEventNumber\": 1,\n"
" \"sessionImpressionNumber\": 1,\n"
" \"sessionNumber\": 2,\n"
" \"subscriptionStatus\": \"free\",\n"
" \"timestamp\": 1659778581.808\n"
" },\n"
" {\n"
" \"campaignName\": \"Nested: Paid Offer 1\",\n"
" \"campaignTypeImpressionNumber\": 3,\n"
" \"campaignTypeSessionImpressionNumber\": 1,\n"
" \"eventName\": \"mainLto3\",\n"
" \"eventNumber\": 1,\n"
" \"impressionNumber\": 1,\n"
" \"inAppStatus\": \"paying\",\n"
" \"isDefaultConfig\": false,\n"
" \"maxLevel\": 0,\n"
" \"mode\": \"default\",\n"
" \"parameters\": {\n"
" \"tleName\": \"summertle\"\n"
" },\n"
" \"sessionEventNumber\": 1,\n"
" \"sessionImpressionNumber\": 1,\n"
" \"sessionNumber\": 2,\n"
" \"subscriptionStatus\": \"free\",\n"
" \"timestamp\": 1659778581.809\n"
" },\n"
" {\n"
" \"campaignName\": \"Nested: Paid Offer 2\",\n"
" \"campaignTypeImpressionNumber\": 3,\n"
" \"campaignTypeSessionImpressionNumber\": 1,\n"
" \"eventName\": \"mainLto3\",\n"
" \"eventNumber\": 1,\n"
" \"impressionNumber\": 1,\n"
" \"inAppStatus\": \"paying\",\n"
" \"isDefaultConfig\": false,\n"
" \"maxLevel\": 0,\n"
" \"mode\": \"default\",\n"
" \"parameters\": {\n"
" \"tleName\": \"summertle\"\n"
" },\n"
" \"sessionEventNumber\": 1,\n"
" \"sessionImpressionNumber\": 1,\n"
" \"sessionNumber\": 2,\n"
" \"subscriptionStatus\": \"free\",\n"
" \"timestamp\": 1659778581.809\n"
" },\n"
" {\n"
" \"campaignName\": \"Nested: Paid Offer 3\",\n"
" \"campaignTypeImpressionNumber\": 3,\n"
" \"campaignTypeSessionImpressionNumber\": 1,\n"
" \"eventName\": \"mainLto3\",\n"
" \"eventNumber\": 1,\n"
" \"impressionNumber\": 1,\n"
" \"inAppStatus\": \"paying\",\n"
" \"isDefaultConfig\": false,\n"
" \"maxLevel\": 0,\n"
" \"mode\": \"default\",\n"
" \"parameters\": {\n"
" \"tleName\": \"summertle\"\n"
" },\n"
" \"sessionEventNumber\": 1,\n"
" \"sessionImpressionNumber\": 1,\n"
" \"sessionNumber\": 2,\n"
" \"subscriptionStatus\": \"free\",\n"
" \"timestamp\": 1659778581.81\n"
" }\n"
" ]\n"
" },\n"
" \"jsonrpc\": \"2.0\"\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.