#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*([^a-zA-Z\d\s])).{9,}$"
Local $sString = "Pass2withUnderScore_Case" & @CRLF & _
"Pass2withUnderScore_Case!" & @CRLF & _
"Pass2withUnderScoreCase!" & @CRLF & _
"Pass2withUnderScoreCase" & @CRLF & _
"" & @CRLF & _
"asdfasfdsxxxxxxxxxxxxxxxxxxxxxxxxxxx" & @CRLF & _
"FASDFASDFASDXXXXXXXXXXXXXXXXXXXX" & @CRLF & _
"143241234xxxxxxxxxxxxx" & @CRLF & _
"a1234xxxxxxxxxxxxxxxxxx" & @CRLF & _
"A1234XXXXXXXXXXXXXXXXXXXXXXX" & @CRLF & _
"Pass2withUnderScoreCase" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")