import Foundation
let pattern = #"^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*([^a-zA-Z\d\s])).{9,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Pass2withUnderScore_Case
Pass2withUnderScore_Case!
Pass2withUnderScoreCase!
Pass2withUnderScoreCase
asdfasfdsxxxxxxxxxxxxxxxxxxxxxxxxxxx
FASDFASDFASDXXXXXXXXXXXXXXXXXXXX
143241234xxxxxxxxxxxxx
a1234xxxxxxxxxxxxxxxxxx
A1234XXXXXXXXXXXXXXXXXXXXXXX
Pass2withUnderScoreCase
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)