using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""https(.*?)200x200(.*)""";
string input = @"Some text
{\""url\"": \""https:\/\/www.someurl.com\/200x200\/fsdffsde3e"", \""bbb\""} kljkl
{\""url\"": \""https:\/\/www.someurl.com\/500x500\/fsdffsde3e"", \""bbb\""} kljkl
Some text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}