import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"https(.*?)200x200(.*)\"";
final String string = "Some text\n"
+ "{\\\"url\\\": \\\"https:\\/\\/www.someurl.com\\/200x200\\/fsdffsde3e\", \\\"bbb\\\"} kljkl\n"
+ "{\\\"url\\\": \\\"https:\\/\\/www.someurl.com\\/500x500\\/fsdffsde3e\", \\\"bbb\\\"} kljkl\n"
+ "Some text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}