const regex = /"https(.*?)200x200(.*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"https(.*?)200x200(.*)"', 'gm')
const str = `Some text
{\\"url\\": \\"https:\\/\\/www.someurl.com\\/200x200\\/fsdffsde3e", \\"bbb\\"} kljkl
{\\"url\\": \\"https:\\/\\/www.someurl.com\\/500x500\\/fsdffsde3e", \\"bbb\\"} kljkl
Some text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}