re = /"https(.*?)200x200(.*)"/m
str = 'Some text
{\\"url\\": \\"https:\\/\\/www.someurl.com\\/200x200\\/fsdffsde3e", \\"bbb\\"} kljkl
{\\"url\\": \\"https:\\/\\/www.someurl.com\\/500x500\\/fsdffsde3e", \\"bbb\\"} kljkl
Some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end