# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\b)\w(?=.*?@)/*/gm;t' <<< "tom.cat@email.com
cutie.pie@email.com
captain.america@email.com"