use strict;
my $str = 'tom.cat@email.com
cutie.pie@email.com
captain.america@email.com';
my $regex = qr/(?<!\b)\w(?=.*?@)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";