re = /(?<!\b)\w(?=.*?@)/m
str = 'tom.cat@email.com
cutie.pie@email.com
captain.america@email.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result