using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\b)\w(?=.*?@)";
string substitution = @"*";
string input = @"tom.cat@email.com
cutie.pie@email.com
captain.america@email.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}