$re = '/(?<!\b)\w(?=.*?@)/m';
$str = 'tom.cat@email.com
cutie.pie@email.com
captain.america@email.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;