#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\bwww\.zigsaw\.in\/companies-detail\/\K[^\/]+\/[^\/]+(?=\.html)"
Local $sString = "https://www.zigsaw.in/companies-detail/AU-Small-Finance-Bank-Ltd/65344.html" & @CRLF & _
"" & @CRLF & _
"https://www.zigsaw.in/companies-detail/Foo-BAR-Bank/12345.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.zigsaw.in/companies-detail/Bar-foo-some-bank/6789.html" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")