using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bwww\.zigsaw\.in\/companies-detail\/\K[^\/]+\/[^\/]+(?=\.html)";
string input = @"https://www.zigsaw.in/companies-detail/AU-Small-Finance-Bank-Ltd/65344.html
https://www.zigsaw.in/companies-detail/Foo-BAR-Bank/12345.html
https://www.zigsaw.in/companies-detail/Bar-foo-some-bank/6789.html
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}