import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bwww\\.zigsaw\\.in\\/companies-detail\\/\\K[^\\/]+\\/[^\\/]+(?=\\.html)";
final String string = "https://www.zigsaw.in/companies-detail/AU-Small-Finance-Bank-Ltd/65344.html\n\n"
+ "https://www.zigsaw.in/companies-detail/Foo-BAR-Bank/12345.html\n\n\n"
+ "https://www.zigsaw.in/companies-detail/Bar-foo-some-bank/6789.html\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}