import re
regex = re.compile(r"\bwww\.zigsaw\.in\/companies-detail\/\K[^\/]+\/[^\/]+(?=\.html)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://www.zigsaw.in/companies-detail/AU-Small-Finance-Bank-Ltd/65344.html\n\n"
"https://www.zigsaw.in/companies-detail/Foo-BAR-Bank/12345.html\n\n\n"
"https://www.zigsaw.in/companies-detail/Bar-foo-some-bank/6789.html\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")