$re = '/\bwww\.zigsaw\.in\/companies-detail\/\K[^\/]+\/[^\/]+(?=\.html)/im';
$str = 'https://www.zigsaw.in/companies-detail/AU-Small-Finance-Bank-Ltd/65344.html
https://www.zigsaw.in/companies-detail/Foo-BAR-Bank/12345.html
https://www.zigsaw.in/companies-detail/Bar-foo-some-bank/6789.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);