using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=""num"">(?:\s+)?(?P<num>\d(?:\.\d{2}):?)";
string input = @"<h1>
<span class=""paper-name"">some string</span>
</h1>
<div class=""data-row"">
<span class=""num"">
0.25
</span>
</div>
<div class=""data-row"">
<span class=""num"">
0.25
</span>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}