$re = '/<span class="num">(?:\s+)?(?P<num>\d(?:\.\d{2}):?)/isu';
$str = '<h1>
<span class="paper-name">some string</span>
</h1>
<div class="data-row">
<span class="num">
0.25
</span>
</div>
<div class="data-row">
<span class="num">
0.25
</span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);