re = /<span class="num">(?:\s+)?(?P<num>\d(?:\.\d{2}):?)/i
str = '<h1>
<span class="paper-name">some string</span>
</h1>
<div class="data-row">
<span class="num">
0.25
</span>
</div>
<div class="data-row">
<span class="num">
0.25
</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end