// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?isu)<span class="num">(?:\s+)?(?P<num>\d(?:\.\d{2}):?)"#).unwrap();
let string = "<h1>
<span class=\"paper-name\">some string</span>
</h1>
<div class=\"data-row\">
<span class=\"num\">
0.25
</span>
</div>
<div class=\"data-row\">
<span class=\"num\">
0.25
</span>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}