# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span class=\"num\">(?:\s+)?(?P<num>\d(?:\.\d{2}):?)"
test_str = ("<h1>\n"
" <span class=\"paper-name\">some string</span>\n"
"</h1>\n"
"<div class=\"data-row\">\n"
" <span class=\"num\">\n\n\n"
"0.25\n\n"
"</span>\n"
"</div>\n"
"<div class=\"data-row\">\n"
" <span class=\"num\">\n\n\n"
"0.25\n\n"
"</span>\n"
"</div>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.