using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a_file_\w+\.xml";
string input = @"4345t435
g54t a_file_123.xml rk
greg a_file_j34.xml fger 43t54";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}