// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)a_file_\w+\.xml").unwrap();
let string = "4345t435
g54t a_file_123.xml rk
greg a_file_j34.xml fger 43t54";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}