package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a_file_\w+\.xml`)
var str = `4345t435
g54t a_file_123.xml rk
greg a_file_j34.xml fger 43t54`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}