const regex = /a_file_\w+\.xml/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a_file_\\w+\\.xml', 'gm')
const str = `4345t435
g54t a_file_123.xml rk
greg a_file_j34.xml fger 43t54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}