#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9\n]{17}$"
Local $sString = "ADQQ213323DS2D33S" & @CRLF & _
"ADQQ213323DSDDSDA" & @CRLF & _
"73721GE276G2E1772" & @CRLF & _
"ADQQ213323DSDD" & @CRLF & _
"73721GE276G2E1772345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")