import re
regex = re.compile(r"^[a-zA-Z0-9\n]{17}$", flags=re.MULTILINE)
test_str = ("ADQQ213323DS2D33S\n"
"ADQQ213323DSDDSDA\n"
"73721GE276G2E1772\n"
"ADQQ213323DSDD\n"
"73721GE276G2E1772345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")