$re = '/^[a-zA-Z0-9\n]{17}$/m';
$str = 'ADQQ213323DS2D33S
ADQQ213323DSDDSDA
73721GE276G2E1772
ADQQ213323DSDD
73721GE276G2E1772345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);