import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9\\n]{17}$";
final String string = "ADQQ213323DS2D33S\n"
+ "ADQQ213323DSDDSDA\n"
+ "73721GE276G2E1772\n"
+ "ADQQ213323DSDD\n"
+ "73721GE276G2E1772345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}