const regex = /^[a-zA-Z0-9\n]{17}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9\\n]{17}$', 'gm')
const str = `ADQQ213323DS2D33S
ADQQ213323DSDDSDA
73721GE276G2E1772
ADQQ213323DSDD
73721GE276G2E1772345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}