import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<tr(?:(?!<li)[\\s\\S])*?(ContactUs)[\\s\\S]*?<\\/tr>)";
final String string = " <li class=\"menuItem\">\n"
+ " <a class=\"menuItem\" href=\"/site/News.aspx?section=316&ViewType=Actual&IdType=316\">\n"
+ " <span class=\"posNR\">2.\n"
+ " </span>News<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
+ " asdsdasda </li>\n\n\n"
+ " <tr class=\"menuItem\">\n"
+ " <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
+ " <span class=\"posNR\">3.\n"
+ " </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
+ " </tr>\n\n"
+ " <tr class=\"menuItem\">\n"
+ " <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
+ " <span class=\"posNR\">3.\n"
+ " </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
+ " </tr>\n\n"
+ " <tr class=\"menuItem\">\n"
+ " <a class=\"menuItem\" href=\"/site/ContactUs.aspx?section=510\">\n"
+ " <span class=\"posNR\">3.\n"
+ " </span>Contact Us<span class=\"shortDesc\"></span><span class=\"line\"></span></a>\n"
+ " </tr>\n\n\n"
+ " </ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}