package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9A-Fa-f]{1,2}(?:[:-][0-9A-Fa-f]{0,2}){0,5}$`)
var str = `93:31:13:E1:D3:1A:
93:31:13:E1:D3:1A
93:31:13:E1:D3:1
93:31:13:E1:D3:
93:31:13:E1:D3
93:31:13:E1:D
93:31:13:E1:
93:31:13:E1
93:31:13:E
93:31:13:
93:31:13
93:31:1
93:31:
93:31
93:3
93:
93
9
3E-EB-47-8
84:0C:
3E:EB-47-8
6B-90-8Y-31-D1-7K
37-4H-31`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}