use strict;
my $str = '93:31:13:E1:D3:1A:
93:31:13:E1:D3:1A
93:31:13:E1:D3:1
93:31:13:E1:D3:
93:31:13:E1:D3
93:31:13:E1:D
93:31:13:E1:
93:31:13:E1
93:31:13:E
93:31:13:
93:31:13
93:31:1
93:31:
93:31
93:3
93:
93
9
3E-EB-47-8
84:0C:
3E:EB-47-8
6B-90-8Y-31-D1-7K
37-4H-31';
my $regex = qr/^[0-9A-Fa-f]{1,2}(?:[:-][0-9A-Fa-f]{0,2}){0,5}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}