import Foundation
let pattern = #"^[0-9A-Fa-f]{1,2}(?:[:-][0-9A-Fa-f]{0,2}){0,5}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
93:31:13:E1:D3:1A:
93:31:13:E1:D3:1A
93:31:13:E1:D3:1
93:31:13:E1:D3:
93:31:13:E1:D3
93:31:13:E1:D
93:31:13:E1:
93:31:13:E1
93:31:13:E
93:31:13:
93:31:13
93:31:1
93:31:
93:31
93:3
93:
93
9
3E-EB-47-8
84:0C:
3E:EB-47-8
6B-90-8Y-31-D1-7K
37-4H-31
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)