import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9A-Fa-f]{1,2}(?:[:-][0-9A-Fa-f]{0,2}){0,5}$";
final String string = "93:31:13:E1:D3:1A:\n"
+ "93:31:13:E1:D3:1A\n"
+ "93:31:13:E1:D3:1\n"
+ "93:31:13:E1:D3:\n"
+ "93:31:13:E1:D3\n"
+ "93:31:13:E1:D\n"
+ "93:31:13:E1:\n"
+ "93:31:13:E1\n"
+ "93:31:13:E\n"
+ "93:31:13:\n"
+ "93:31:13\n"
+ "93:31:1\n"
+ "93:31:\n"
+ "93:31\n"
+ "93:3\n"
+ "93:\n"
+ "93\n"
+ "9\n"
+ "3E-EB-47-8\n"
+ "84:0C:\n\n"
+ "3E:EB-47-8\n\n"
+ "6B-90-8Y-31-D1-7K\n"
+ "37-4H-31";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}