# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9A-Fa-f]{1,2}(?:[:-][0-9A-Fa-f]{0,2}){0,5}$"
test_str = ("93:31:13:E1:D3:1A:\n"
"93:31:13:E1:D3:1A\n"
"93:31:13:E1:D3:1\n"
"93:31:13:E1:D3:\n"
"93:31:13:E1:D3\n"
"93:31:13:E1:D\n"
"93:31:13:E1:\n"
"93:31:13:E1\n"
"93:31:13:E\n"
"93:31:13:\n"
"93:31:13\n"
"93:31:1\n"
"93:31:\n"
"93:31\n"
"93:3\n"
"93:\n"
"93\n"
"9\n"
"3E-EB-47-8\n"
"84:0C:\n\n"
"3E:EB-47-8\n\n"
"6B-90-8Y-31-D1-7K\n"
"37-4H-31")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.