package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(^[a-z]{1}(emi)|(m[a-z]{1}se))`)
var str = `hemidemisemiquaver
emi - курсив
m.se - жирным
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}